summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorsilverwind <me@silverwind.io>2023-06-18 20:13:08 +0200
committerGitHub <noreply@github.com>2023-06-18 18:13:08 +0000
commit1a0a20546699021c547ffb4cc4979bf334b39b53 (patch)
treeb5b19896488b5f79464d036c7b15de14b0287081 /pyproject.toml
parentbfab129fb97479e2efaaa0ece7071e13d79629ed (diff)
downloadgitea-1a0a20546699021c547ffb4cc4979bf334b39b53.tar.gz
gitea-1a0a20546699021c547ffb4cc4979bf334b39b53.zip
Clean up pyproject.toml and package.json, fix poetry options (#25327)
- Reduce `pyproject.toml` and `package.json` to the minimal required format, removing unneeded properties. `build-system` is not needed as per [this](https://github.com/python-poetry/poetry/issues/8110#issuecomment-1595846841). - Fix `poetry.toml` options they were wrong previously. - Add dependencies of poetry files to templates `files-changed`. --------- Co-authored-by: Giteabot <teabot@gitea.io>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 0 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index d5151bd480..ce5f475b27 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -13,7 +13,3 @@ djlint = "1.31.0"
[tool.djlint]
profile="golang"
ignore="H005,H006,H008,H013,H014,H016,H020,H021,H023,H026,H030,H031,T027"
-
-[build-system]
-requires = ["poetry-core"]
-build-backend = "poetry.core.masonry.api"