aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorsilverwind <me@silverwind.io>2023-06-14 20:17:58 +0200
committerGitHub <noreply@github.com>2023-06-14 18:17:58 +0000
commite24f651c86a5168da8181f2c75f5f99b56561224 (patch)
tree1f604dc894e29a0c99adca856bd55ad1ca78d4be /pyproject.toml
parenta0eaf0881235d41ca98f4718af815908d1237d2c (diff)
downloadgitea-e24f651c86a5168da8181f2c75f5f99b56561224.tar.gz
gitea-e24f651c86a5168da8181f2c75f5f99b56561224.zip
Add template linting via djlint (#25212)
So I found this [linter](https://github.com/Riverside-Healthcare/djlint) which features a mode for go templates, so I gave it a try and it did find a number of valid issue, like unbalanced tags etc. It also has a number of bugs, I had to disable/workaround many issues. Given that this linter is written in python, this does add a dependency on `python` >= 3.8 and `poetry` to the development environment to be able to run this linter locally. - `e.g.` prefixes on placeholders are removed because the linter had a false-positive on `placeholder="e.g. cn=Search"` for the `attr=value` syntax and it's not ideal anyways to write `e.g.` into a placeholder because a placeholder is meant to hold a sample value. - In `templates/repo/settings/options.tmpl` I simplified the logic to not conditionally create opening tags without closing tags because this stuff confuses the linter (and possibly the reader as well).
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000000..d5151bd480
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,19 @@
+[tool.poetry]
+name = "gitea"
+version = "0.0.0"
+description = ""
+authors = []
+
+[tool.poetry.dependencies]
+python = "^3.8"
+
+[tool.poetry.group.dev.dependencies]
+djlint = "1.31.0"
+
+[tool.djlint]
+profile="golang"
+ignore="H005,H006,H008,H013,H014,H016,H020,H021,H023,H026,H030,H031,T027"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"