Browse Source

Add missing fields to OSGi manifests

Adds RequiredExecutionEnvironment and License fields and renames some
bundles (SymbolicName) for backwards compatibility.
tags/8.1.0.alpha7
Henri Sara 3 years ago
parent
commit
df060e265a

+ 3
- 1
client-compiled/bnd.bnd View File

@@ -1,6 +1,8 @@
Bundle-SymbolicName: ${project.groupId}.client.compiled
Bundle-SymbolicName: ${project.groupId}.client-compiled
Bundle-Name: Default Widgetset
Bundle-Version: ${osgi.bundle.version}
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin*;version='[${osgi.bundle.version},${osgi.bundle.version}]',\
*
Export-Package: com.vaadin.osgi.widgetset;-noimport:=true

+ 3
- 1
compatibility-client-compiled/bnd.bnd View File

@@ -1,6 +1,8 @@
Bundle-SymbolicName: ${project.groupId}.compatibility.client.compiled
Bundle-SymbolicName: ${project.groupId}.compatibility-client-compiled
Bundle-Name: Compatibility Widgetset
Bundle-Version: ${osgi.bundle.version}
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin*;version='[${osgi.bundle.version},${osgi.bundle.version}]',\
*
Export-Package: com.vaadin.osgi.compatibility.widgetset;-noimport:=true

+ 3
- 1
compatibility-server/bnd.bnd View File

@@ -1,5 +1,7 @@
Bundle-SymbolicName: ${project.groupId}.compatibility.server
Bundle-SymbolicName: ${project.groupId}.compatibility-server
Bundle-Name: Vaadin Compatibility Server
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin*;version="[${osgi.bundle.version},${osgi.bundle.version}]",\
org.osgi*,\
javax.validation*;resolution:=optional;version='${javax.validation.version}',\

+ 3
- 1
compatibility-shared/bnd.bnd View File

@@ -1,5 +1,7 @@
Bundle-SymbolicName: ${project.groupId}.compatibility.shared
Bundle-SymbolicName: ${project.groupId}.compatibility-shared
Bundle-Name: Vaadin Compatibility Shared
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin*;version="[${osgi.bundle.version},${osgi.bundle.version}]",\
org.osgi*
Export-Package: \

+ 3
- 1
compatibility-themes/bnd.bnd View File

@@ -1,6 +1,8 @@
Bundle-SymbolicName: ${project.groupId}.compatibility.themes
Bundle-SymbolicName: ${project.groupId}.compatibility-themes
Bundle-Name: Vaadin Compatibility Themes
Bundle-Version: ${osgi.bundle.version}
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin*;version='[${osgi.bundle.version},${osgi.bundle.version}]',\
*
Export-Package: com.vaadin.osgi.compatibility.themes;-noimport:=true

+ 2
- 0
liferay-integration/bnd.bnd View File

@@ -1,6 +1,8 @@
Bundle-SymbolicName: ${project.groupId}.liferay.integration
Bundle-Name: Vaadin Liferay Integration
Bundle-Version: ${osgi.bundle.version}
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin.*;version='[${osgi.bundle.version},${osgi.bundle.version}]',\
*
Export-Package: com.vaadin.osgi.liferay*;-noimport:=true

+ 2
- 0
osgi-integration/bnd.bnd View File

@@ -1,6 +1,8 @@
Bundle-SymbolicName: ${project.groupId}.osgi.integration
Bundle-Name: Vaadin OSGi Integration
Bundle-Version: ${osgi.bundle.version}
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin.*;version='[${osgi.bundle.version},${osgi.bundle.version}]',\
*


+ 2
- 0
push/bnd.bnd View File

@@ -1,6 +1,8 @@
Bundle-SymbolicName: ${project.groupId}.push
Bundle-Name: Vaadin Push
Bundle-Version: ${osgi.bundle.version}
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin*;version='[${osgi.bundle.version},${osgi.bundle.version}]',\
*
Export-Package: com.vaadin.osgi.push;-noimport:=true

+ 2
- 0
server/bnd.bnd View File

@@ -1,6 +1,8 @@
Bundle-SymbolicName: ${project.groupId}.server
Bundle-Name: Vaadin Server
Bundle-Version: ${osgi.bundle.version}
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin.sass.*;resolution:=optional,\
com.liferay.portal.kernel.util;resolution:=optional,\
javax.portlet*;resolution:=optional,\

+ 2
- 0
shared/bnd.bnd View File

@@ -1,6 +1,8 @@
Bundle-SymbolicName: ${project.groupId}.shared
Bundle-Activator: com.vaadin.osgi.resources.OSGiVaadinResources
Bundle-Name: Vaadin Shared
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin*;version="[${osgi.bundle.version},${osgi.bundle.version}]",\
org.osgi*
Export-Package: com.vaadin.osgi.resources;-noimport:=true,\

+ 2
- 0
themes/bnd.bnd View File

@@ -1,6 +1,8 @@
Bundle-SymbolicName: ${project.groupId}.themes
Bundle-Name: Vaadin Themes
Bundle-Version: ${osgi.bundle.version}
Bundle-RequiredExecutionEnvironment: JavaSE-1.8
Bundle-License: http://www.apache.org/licenses/LICENSE-2.0
Import-Package: com.vaadin.*;version='[${osgi.bundle.version},${osgi.bundle.version}]',\
*
Export-Package: com.vaadin.osgi.themes;-noimport:=true

Loading…
Cancel
Save