aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rambler-co.ru>2010-05-31 17:17:13 +0400
committerVsevolod Stakhov <vsevolod@rambler-co.ru>2010-05-31 17:17:13 +0400
commit0612e84b3cec508c3d62d38c4e2682c85cc808bb (patch)
treedb777e38f9c528127e195ad01da6a3088dc6da4a /CMakeLists.txt
parentae3eb4dfd787052bebc732c3e37b56f0800e1aa2 (diff)
downloadrspamd-0612e84b3cec508c3d62d38c4e2682c85cc808bb.tar.gz
rspamd-0612e84b3cec508c3d62d38c4e2682c85cc808bb.zip
* Fix strict aliasing while compiling with optimization
* Fix tanhl detection for platforms that have not implementation of it * Remove several compile warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 615cbb52f..233741405 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -280,6 +280,7 @@ CHECK_FUNCTION_EXISTS(vfork HAVE_VFORK)
CHECK_FUNCTION_EXISTS(wait4 HAVE_WAIT4)
CHECK_FUNCTION_EXISTS(waitpid HAVE_WAITPID)
CHECK_FUNCTION_EXISTS(flock HAVE_FLOCK)
+CHECK_FUNCTION_EXISTS(tanhl HAVE_TANHL)
CHECK_SYMBOL_EXISTS(PATH_MAX limits.h HAVE_PATH_MAX)
CHECK_SYMBOL_EXISTS(MAXPATHLEN sys/param.h HAVE_MAXPATHLEN)