aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2014-09-05 11:21:42 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2014-09-05 11:21:42 +0100
commite48534950a62f569aafd892b2cb810c9a6725e7b (patch)
tree99c5f057b509c248cc215f4fb4a075489628ed03 /CMakeLists.txt
parent2ad4f0abc90c2017041f4734f31fc3ffe9610188 (diff)
downloadrspamd-e48534950a62f569aafd892b2cb810c9a6725e7b.tar.gz
rspamd-e48534950a62f569aafd892b2cb810c9a6725e7b.zip
Add 'dist' target.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 889debe88..8091bb802 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -925,4 +925,9 @@ INSTALL(FILES "doc/rspamc.1" DESTINATION ${MANDIR}/man1)
# Install webui
IF(INSTALL_WEBUI MATCHES "ON")
INSTALL(DIRECTORY "interface/" DESTINATION ${WWWDIR} PATTERN ".git" EXCLUDE)
-ENDIF(INSTALL_WEBUI MATCHES "ON") \ No newline at end of file
+ENDIF(INSTALL_WEBUI MATCHES "ON")
+
+ADD_CUSTOM_TARGET(dist ${CMAKE_SOURCE_DIR}/dist.sh
+ "${CMAKE_BINARY_DIR}/rspamd-${RSPAMD_VERSION}.tar.xz"
+ COMMENT "Create source distribution"
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}) \ No newline at end of file