aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2014-09-01 11:37:28 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2014-09-01 11:59:51 +0100
commita509f5c41a762ce962171a8e3d5968ed14ee2c25 (patch)
tree1b249e43d0e8253d77f9a31a875f51c481648b11 /CMakeLists.txt
parent55782441ab13c4f3f6945ec75deb88c42e2727b6 (diff)
downloadrspamd-a509f5c41a762ce962171a8e3d5968ed14ee2c25.tar.gz
rspamd-a509f5c41a762ce962171a8e3d5968ed14ee2c25.zip
Prepare for release.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44a3f7e38..889debe88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,6 +38,7 @@ OPTION(ENABLE_URL_INCLUDE "Enable urls in ucl includes (requires libcurl or lib
OPTION(NO_SHARED "Build internal libs static [default: OFF]" OFF)
OPTION(FORCE_GMIME24 "Link with gmime2.4 [default: OFF]" OFF)
OPTION(INSTALL_EXAMPLES "Install examples [default: OFF]" OFF)
+OPTION(INSTALL_WEBUI "Install web interface [default: ON]" ON)
# Build optimized code for following CPU (default i386)
#SET(CPU_TUNE "i686")
@@ -920,3 +921,8 @@ ENDIF(CMAKE_SYSTEM_NAME STREQUAL "Linux")
# Manual pages
INSTALL(FILES "doc/rspamd.8" DESTINATION ${MANDIR}/man8)
INSTALL(FILES "doc/rspamc.1" DESTINATION ${MANDIR}/man1)
+
+# Install webui
+IF(INSTALL_WEBUI MATCHES "ON")
+ INSTALL(DIRECTORY "interface/" DESTINATION ${WWWDIR} PATTERN ".git" EXCLUDE)
+ENDIF(INSTALL_WEBUI MATCHES "ON") \ No newline at end of file