aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-06-16 17:39:26 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-06-16 19:16:56 +0100
commit3275500a984c39c768e54a02c4bc08f960ed7eec (patch)
tree930b6db758adc88e6964462b7f0ed80bc2b1db40 /CMakeLists.txt
parent516c1bb74ba3f9632531a0913082f45395d56a8a (diff)
downloadrspamd-3275500a984c39c768e54a02c4bc08f960ed7eec.tar.gz
rspamd-3275500a984c39c768e54a02c4bc08f960ed7eec.zip
Use specific POE loop for some systems.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eea8470b2..2af631c87 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -420,6 +420,8 @@ IF(NOT BUILD_CPU_MODE)
ENDIF(AMD_64)
ENDIF(NOT BUILD_CPU_MODE)
+SET(POE_LOOP "POE::Loop::IO_Poll")
+
# Platform specific configuration
IF(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D_BSD_SOURCE -DFREEBSD")
@@ -449,6 +451,7 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
CHECK_FUNCTION_EXISTS(pidfile_fileno HAVE_PIDFILE_FILENO)
ENDIF(_LIBUTIL_H)
ENDIF(LIBUTIL_LIBRARY)
+ SET(POE_LOOP "POE::Loop::Kqueue")
ENDIF(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
IF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
@@ -458,6 +461,7 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -pagezero_size 10000 -image_base 100000000")
ENDIF(ENABLE_LUAJIT MATCHES "ON")
MESSAGE(STATUS "Configuring for Darwin")
+ SET(POE_LOOP "POE::Loop::Kqueue")
ENDIF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
@@ -484,6 +488,7 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "Linux")
ELSE(EXISTS "/etc/debian_version")
SET(LINUX_START_SCRIPT "rspamd_rh.in")
ENDIF(EXISTS "/etc/debian_version")
+ SET(POE_LOOP "POE::XS::Loop::EPoll")
ENDIF(CMAKE_SYSTEM_NAME STREQUAL "Linux")
IF(CMAKE_SYSTEM_NAME STREQUAL "SunOS")