aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-03-13 11:23:31 +0000
committerAndrew Lewis <nerf@judo.za.org>2015-03-17 23:43:10 +0200
commit63b38d572fd0bc2fe57daeaa51a03a5ef4c83fad (patch)
tree9d67217c8390d2e8ca945b3a6be0dd02c90e90b3 /CMakeLists.txt
parentea03c989d5d908a16373abf91e35c1f6a57a509c (diff)
downloadrspamd-63b38d572fd0bc2fe57daeaa51a03a5ef4c83fad.tar.gz
rspamd-63b38d572fd0bc2fe57daeaa51a03a5ef4c83fad.zip
Add specific workaround for debian.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55bd79523..31db0b8c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1062,6 +1062,10 @@ IF(BUILD_PORT)
ELSE(BUILD_PORT)
INSTALL_IF_NOT_EXISTS(${MAIN_CONF} ${CONFDIR} "rspamd.conf" "")
ENDIF(BUILD_PORT)
+# Debian is also special
+IF(DEBIAN_BUILD)
+ INSTALL_IF_NOT_EXISTS("conf/rspamd.sysvinit.conf" ${CONFDIR} "rspamd.sysvinit.conf" "")
+ENDIF(DEBIAN_BUILD)
IF(INSTALL_EXAMPLES MATCHES "ON")
INSTALL(FILES ${MAIN_CONF} DESTINATION ${EXAMPLESDIR})
ENDIF(INSTALL_EXAMPLES MATCHES "ON")