aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2014-12-17 18:30:17 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2014-12-17 18:30:17 +0000
commite6d21cd892f516cdad4906c7f6366e3fc95066d4 (patch)
treeface93677f9b66110854f21fe5207d7aaa9f077a /CMakeLists.txt
parent5bcf9f0af263b25ab6c5b128e767cc8a2a39312a (diff)
parent74fc525324621df7d278058fe706481f36bdc523 (diff)
downloadrspamd-e6d21cd892f516cdad4906c7f6366e3fc95066d4.tar.gz
rspamd-e6d21cd892f516cdad4906c7f6366e3fc95066d4.zip
Merge branch 'shingles'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58b9b6471..be81d3eeb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ IF(NOT RSPAMD_USER)
ENDIF(NOT RSPAMD_USER)
CMAKE_MINIMUM_REQUIRED(VERSION 2.6.0 FATAL_ERROR)
+SET_PROPERTY(GLOBAL PROPERTY ALLOW_DUPLICATE_CUSTOM_TARGETS 1)
############################# OPTIONS SECTION #############################################
@@ -830,6 +831,8 @@ INCLUDE_DIRECTORIES("${CMAKE_SOURCE_DIR}/src"
"${CMAKE_SOURCE_DIR}/contrib/http-parser"
"${CMAKE_SOURCE_DIR}/contrib/libottery"
"${CMAKE_SOURCE_DIR}/contrib/xxhash"
+ "${CMAKE_SOURCE_DIR}/contrib/snowball/include"
+ "${CMAKE_SOURCE_DIR}/contrib/siphash"
"${CMAKE_SOURCE_DIR}/src/rdns/include")
################################ SUBDIRS SECTION ###########################
@@ -850,6 +853,7 @@ ADD_SUBDIRECTORY(contrib/xxhash)
ADD_SUBDIRECTORY(contrib/http-parser)
ADD_SUBDIRECTORY(contrib/libottery)
ADD_SUBDIRECTORY(contrib/snowball)
+ADD_SUBDIRECTORY(contrib/siphash)
ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(test)
@@ -936,3 +940,6 @@ ADD_CUSTOM_TARGET(dist ${CMAKE_SOURCE_DIR}/dist.sh
"${CMAKE_BINARY_DIR}/rspamd-${RSPAMD_VERSION}.tar.xz"
COMMENT "Create source distribution"
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
+
+ADD_CUSTOM_TARGET(check DEPENDS rspamd-test)
+ADD_CUSTOM_TARGET(run-test DEPENDS check COMMAND test/rspamd-test) \ No newline at end of file