summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrej Zverev <andrej.zverev@gmail.com>2015-03-12 01:25:26 +0300
committerAndrew Lewis <nerf@judo.za.org>2015-03-17 21:31:35 +0200
commitd8f17b061835e7d59f464ad8a7c4036495232b96 (patch)
tree1c42eb33436101b145a486ad8ec51516f20c070b /CMakeLists.txt
parent68a8b5e094d7aea2539a652c5e9046d4eacad4a9 (diff)
downloadrspamd-d8f17b061835e7d59f464ad8a7c4036495232b96.tar.gz
rspamd-d8f17b061835e7d59f464ad8a7c4036495232b96.zip
Use Systemd for Linux family and SysV for other systems.
We are creating conf/rspamd.conf.in as template and declaring two new variables for CMake: DEFAULTS (for SysV): RSPAMD_WORKER_NORMAL = "*:11333" RSPAMD_WORKER_CONTROLLER = "*:11334" For Linux (for Systemd): RSPAMD_WORKER_NORMAL = "systemd:0" RSPAMD_WORKER_CONTROLLER = "systemd:1" During build we replace template with correct values. Conflicts: CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 69ddd7d3d..e12ad0e96 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,9 @@ IF(NOT RSPAMD_USER)
ENDIF(NOT RSPAMD_USER)
CMAKE_MINIMUM_REQUIRED(VERSION 2.8.0 FATAL_ERROR)
+# Default for SysV Init
+SET(RSPAMD_WORKER_NORMAL "*:11333")
+SET(RSPAMD_WORKER_CONTROLLER "*:11334")
SET_PROPERTY(GLOBAL PROPERTY ALLOW_DUPLICATE_CUSTOM_TARGETS 1)
############################# OPTIONS SECTION #############################################
@@ -346,6 +349,9 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "Linux")
ELSE(EXISTS "/etc/debian_version")
SET(LINUX_START_SCRIPT "rspamd_rh.in")
ENDIF(EXISTS "/etc/debian_version")
+ # Overwrite to conform systemd
+ SET(RSPAMD_WORKER_NORMAL "systemd:0")
+ SET(RSPAMD_WORKER_CONTROLLER "systemd:1")
ENDIF(CMAKE_SYSTEM_NAME STREQUAL "Linux")
IF(CMAKE_SYSTEM_NAME STREQUAL "SunOS")
@@ -394,6 +400,9 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "SunOS")
SET(CMAKE_INSTALL_RPATH "${PREFIX}/lib")
ENDIF(CMAKE_SYSTEM_NAME STREQUAL "SunOS")
+# Create conf/rspamd.conf from template
+CONFIGURE_FILE(conf/rspamd.conf.in conf/rspamd.conf @ONLY)
+
# Now find libraries and headers
# Find lua libraries