summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2016-11-26 13:08:03 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2016-11-26 13:08:03 +0000
commitd2ae2538f1d07a09235778de2b7a36e72e7dde60 (patch)
tree2014311ab4f70ec4d568eb4d635abb596cf3c582 /CMakeLists.txt
parentb6ceb8518d29def9ec450ed0f4ae96959d4851a8 (diff)
downloadrspamd-d2ae2538f1d07a09235778de2b7a36e72e7dde60.tar.gz
rspamd-d2ae2538f1d07a09235778de2b7a36e72e7dde60.zip
[Minor] Add missing flag
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c9d1f7b6d..2e19f43ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -660,6 +660,7 @@ ProcessPackage(GMODULE2 LIBRARY gmodule-2.0 INCLUDE glib.h
IF(GLIB_ROOT_DIR)
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES "-lpthread")
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES "-lffi")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
ENDIF()
IF(ENABLE_PCRE2 MATCHES "ON")