summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2014-09-30 12:52:31 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2014-09-30 12:53:05 +0100
commit7a83d76dc12389438bbe3b0b29cc82b7740a3796 (patch)
treef9868abd09256aa7d70279affc0608897e0b49fe /CMakeLists.txt
parent856ce4356e307916f7d922bd07cbdb69f4e74069 (diff)
downloadrspamd-7a83d76dc12389438bbe3b0b29cc82b7740a3796.tar.gz
rspamd-7a83d76dc12389438bbe3b0b29cc82b7740a3796.zip
Release 0.7.1.0.7.1
* Fix typo in stat output. * Fix issues with includes crossing with the system includes * Restore testing framework * Add radix trie test suite * Implement new path-compressed radix trie. - The performance benefit over the old algorithm is about 1.5 times. - Memory usage is significantly lower as well. - Now radix trie can accept any IPv4/IPv6 values * Various improvements to the memory pools code * Fix writing reply to a client when no filters are defined * Write base32 encoded fuzzy * Fix 'soft reject' action * Fix rspamd reload and modules reconfiguration * Fix subject rewriting for the default subject * Fix states for processing task and pre-filters * Fix issues with connection closing * Fix crashes in rdns * Fix ratelimit pre-filter * Update exim patch. - Update to the recent exim version - Strip extra leading src/ from the patch - Remove sendfile since it was broken - Fix rspamd spam report for exim * Improve documentation Signed-off-by: Vsevolod Stakhov <vsevolod@highsecure.ru>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index efd760cd8..8ef006622 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ PROJECT(rspamd C)
SET(RSPAMD_VERSION_MAJOR 0)
SET(RSPAMD_VERSION_MINOR 7)
-SET(RSPAMD_VERSION_PATCH 0)
+SET(RSPAMD_VERSION_PATCH 1)
SET(RSPAMD_VERSION "${RSPAMD_VERSION_MAJOR}.${RSPAMD_VERSION_MINOR}.${RSPAMD_VERSION_PATCH}")
SET(RSPAMD_MASTER_SITE_URL "https://rspamd.com")
@@ -933,4 +933,4 @@ ENDIF(INSTALL_WEBUI MATCHES "ON")
ADD_CUSTOM_TARGET(dist ${CMAKE_SOURCE_DIR}/dist.sh
"${CMAKE_BINARY_DIR}/rspamd-${RSPAMD_VERSION}.tar.xz"
COMMENT "Create source distribution"
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}) \ No newline at end of file
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})