summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2020-12-27 22:41:12 +0000
committerDuncan Bellamy <dunk@denkimushi.com>2020-12-29 23:20:38 +0000
commitd7738db6970c4cd838be067293abcdb5abc6a71c (patch)
treea7f54443bbb3ac6cc19522b113afff96e2899958 /CMakeLists.txt
parentd6fcb8bd182e9646166ef446a1dfd03eff6417f0 (diff)
downloadrspamd-d7738db6970c4cd838be067293abcdb5abc6a71c.tar.gz
rspamd-d7738db6970c4cd838be067293abcdb5abc6a71c.zip
[Minor] Fix some compiler warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 076656dee..72382acb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,8 @@ SET(RSPAMD_VERSION "${RSPAMD_VERSION_MAJOR}.${RSPAMD_VERSION_MINOR}")
PROJECT(rspamd VERSION "${RSPAMD_VERSION}" LANGUAGES C CXX ASM)
+CMAKE_POLICY(SET CMP0075 NEW)
+
# This is supported merely with cmake 3.1
SET(CMAKE_C_STANDARD 11)
SET(CMAKE_C_STANDARD_REQUIRED ON)