summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey AL <AlexeySa@users.noreply.github.com>2015-02-09 01:21:43 +0300
committerAlexey AL <AlexeySa@users.noreply.github.com>2015-02-09 01:21:43 +0300
commitbff11b8665e1e9319eae2584508d3bc00588b7e8 (patch)
tree723c2384a2dbffa13e31c9ed0542b35e784bac71 /CMakeLists.txt
parent7f1ad00467415ca80d22e9865dab0792a9ee27fa (diff)
downloadrspamd-bff11b8665e1e9319eae2584508d3bc00588b7e8.tar.gz
rspamd-bff11b8665e1e9319eae2584508d3bc00588b7e8.zip
Add static build internal libs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 50e68c7dc..e6e11fd9d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,7 +36,7 @@ OPTION(ENABLE_DB "Find and link with DB library [default: OFF]"
OPTION(ENABLE_SQLITE "Find and link with sqlite3 library [default: OFF]" OFF)
OPTION(ENABLE_HIREDIS "Find and link with external redis library [default: OFF]" OFF)
OPTION(ENABLE_URL_INCLUDE "Enable urls in ucl includes (requires libcurl or libfetch) [default: OFF]" OFF)
-OPTION(NO_SHARED "Build internal libs static [default: OFF]" OFF)
+OPTION(NO_SHARED "Build internal libs static [default: ON]" ON)
OPTION(FORCE_GMIME24 "Link with gmime2.4 [default: OFF]" OFF)
OPTION(INSTALL_EXAMPLES "Install examples [default: OFF]" OFF)
OPTION(INSTALL_WEBUI "Install web interface [default: ON]" ON)