summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2021-06-23 14:01:36 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2021-06-23 14:01:36 +0100
commiteaac9aab159e4832bd34ab1ed24ff39a214925fb (patch)
tree8f8c77093708101bfd832b9503d021fcda6f3006 /CMakeLists.txt
parentdf0fc37fd60c71e190a74be8222e2a007e7824cb (diff)
downloadrspamd-eaac9aab159e4832bd34ab1ed24ff39a214925fb.tar.gz
rspamd-eaac9aab159e4832bd34ab1ed24ff39a214925fb.zip
[Minor] Fix FreeBSD release build with lld/libc++
Issue: #3778
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b46de3f4d..ac806f936 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -255,6 +255,8 @@ SET(CMAKE_CXX_FLAGS "${CMAKE_C_OPT_FLAGS} ${CMAKE_CXX_FLAGS}")
ADD_DEFINITIONS(-DHAVE_CONFIG_H)
ADD_DEFINITIONS(-DDOCTEST_CONFIG_NO_MULTI_LANE_ATOMICS)
+# Workaround for https://github.com/onqtam/doctest/issues/356
+ADD_DEFINITIONS(-DDOCTEST_CONFIG_USE_STD_HEADERS)
ADD_DEFINITIONS(-DU_CHARSET_IS_UTF8)
# Check platform specific includes