summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorcebka@lenovo-laptop <cebka@lenovo-laptop>2010-02-25 18:55:40 +0300
committercebka@lenovo-laptop <cebka@lenovo-laptop>2010-02-25 18:55:40 +0300
commit2cab3a9c488cb9042acf4350dc327a7dcb0c9eb9 (patch)
tree981fc9c30d87a66d15c0804ba62e56dde8505af6 /CMakeLists.txt
parentc6636a9fc339468d02b47498945711d25623b3e5 (diff)
downloadrspamd-2cab3a9c488cb9042acf4350dc327a7dcb0c9eb9.tar.gz
rspamd-2cab3a9c488cb9042acf4350dc327a7dcb0c9eb9.zip
* Add first custom filter for making marks for ip addresses and networks
* Some additions to radix tree library: - allow tree traverse - add new insert methods (add and replace) - store keys in radix nodes (thought we can calculate key by bits, but I think that storing key is not too expensive) - values in a tree are now uintptr_t
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 099798137..58a823c29 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,7 @@ PROJECT(rspamd C)
SET(RSPAMD_VERSION_MAJOR 0)
SET(RSPAMD_VERSION_MINOR 2)
-SET(RSPAMD_VERSION_PATCH 8)
+SET(RSPAMD_VERSION_PATCH 9)
SET(RSPAMD_VERSION "${RSPAMD_VERSION_MAJOR}.${RSPAMD_VERSION_MINOR}.${RSPAMD_VERSION_PATCH}")
SET(RSPAMD_MASTER_SITE_URL "http://cebka.pp.ru/hg/rspamd")
@@ -412,6 +412,7 @@ ENDIF(ENABLE_LUA MATCHES "ON")
ADD_SUBDIRECTORY(src/json)
ADD_SUBDIRECTORY(src/evdns)
+ADD_SUBDIRECTORY(src/plugins/custom)
SET(TOKENIZERSSRC src/tokenizers/tokenizers.c
src/tokenizers/osb.c)