summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-03-13 11:23:31 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-03-13 12:03:28 +0000
commit071744413350b8643cfa287b5279f0486b3516f0 (patch)
tree4f26c76ca3e41e2f7a07ee90a5d7028f48e08541 /CMakeLists.txt
parente7bafe926e1f02a71fe0782be32663829d955d88 (diff)
downloadrspamd-071744413350b8643cfa287b5279f0486b3516f0.tar.gz
rspamd-071744413350b8643cfa287b5279f0486b3516f0.zip
Add specific workaround for debian.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d6d7e853..8aba1a0e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1061,6 +1061,10 @@ IF(BUILD_PORT)
ELSE(BUILD_PORT)
INSTALL_IF_NOT_EXISTS(${MAIN_CONF} ${CONFDIR} "rspamd.conf" "")
ENDIF(BUILD_PORT)
+# Debian is also special
+IF(DEBIAN_BUILD)
+ INSTALL_IF_NOT_EXISTS("conf/rspamd.sysvinit.conf" ${CONFDIR} "rspamd.sysvinit.conf" "")
+ENDIF(DEBIAN_BUILD)
IF(INSTALL_EXAMPLES MATCHES "ON")
INSTALL(FILES ${MAIN_CONF} DESTINATION ${EXAMPLESDIR})
ENDIF(INSTALL_EXAMPLES MATCHES "ON")