summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2017-11-05 14:34:22 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2017-11-05 14:34:22 +0000
commit33fed0759994c27f164d0b4ca6c420e7376bef83 (patch)
tree9daf2ca52a96cfda8cccbf310d95e8851c364f4a /CMakeLists.txt
parent111dfde1ad75526cecfcdd09d79bbd07454c8b0a (diff)
downloadrspamd-33fed0759994c27f164d0b4ca6c420e7376bef83.tar.gz
rspamd-33fed0759994c27f164d0b4ca6c420e7376bef83.zip
[Feature] Add torch-decisiontree package
https://github.com/twitter/torch-decisiontree This project implements random forests and gradient boosted decision trees (GBDT). The latter uses gradient tree boosting. Both use ensemble learning to produce ensembles of decision trees (that is, forests).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8256f5f39..0376739b8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1284,6 +1284,7 @@ IF(ENABLE_TORCH MATCHES "ON")
ADD_SUBDIRECTORY(contrib/torch/paths)
ADD_SUBDIRECTORY(contrib/torch/torch7)
ADD_SUBDIRECTORY(contrib/torch/nn)
+ ADD_SUBDIRECTORY(contrib/torch/decisiontree)
SET(WITH_TORCH 1)
ELSE()
MESSAGE(FATAL_ERROR "Cannot enable torch without luajit")