summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Vaněk <pv@excello.cz>2019-11-26 19:16:12 +0100
committerPetr Vaněk <pv@excello.cz>2019-11-26 19:16:12 +0100
commitbbf8bb172d168f16cc90264af1da1f32a42890c3 (patch)
tree526b0bf9201a5939a7780bff8ba6f10beb2d8ef1 /CMakeLists.txt
parentd90b05640bcea0544ea698ccec35abbfd2e313b0 (diff)
downloadrspamd-bbf8bb172d168f16cc90264af1da1f32a42890c3.tar.gz
rspamd-bbf8bb172d168f16cc90264af1da1f32a42890c3.zip
cmake: Unify ENABLE_OPENBLAS and ENABLE_BLAS
ENABLE_OPENBLAS is removed because it was not used to check if the openblas library should be used. The ENABLE_BLAS is moved from CMakeLists.txt to cmake/Openblas.cmake to have all related variables in one file and to reduce a complexity of CMakeLists.txt slightly.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 841ac0a5d..7cd5ef398 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,7 +54,6 @@ OPTION(ENABLE_UTILS "Build rspamd internal utils [default: OFF]" OFF)
OPTION(ENABLE_LIBUNWIND "Use libunwind to print crash traces [default: OFF]" OFF)
OPTION(ENABLE_LUA_TRACE "Trace all Lua C API invocations [default: OFF]" OFF)
OPTION(ENABLE_LUA_REPL "Enables Lua repl (requires C++11 compiler) [default: ON]" ON)
-OPTION(ENABLE_BLAS "Enables libopenblas support [default: OFF]" OFF)
############################# INCLUDE SECTION #############################################