aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rambler-co.ru>2010-06-23 15:13:50 +0400
committerVsevolod Stakhov <vsevolod@rambler-co.ru>2010-06-23 15:13:50 +0400
commit411f4a081f36c8305b6c9b750e8f43fc50beb879 (patch)
treecfa9bb2fa105ce79d614afd29ba0b20e8bbb3041 /CMakeLists.txt
parent18ce6f0c60f1125c5344d9fd8e90e5ea2941bf01 (diff)
downloadrspamd-411f4a081f36c8305b6c9b750e8f43fc50beb879.tar.gz
rspamd-411f4a081f36c8305b6c9b750e8f43fc50beb879.zip
* Fix -lintl detection
* Init some variables to avoid problems
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1605bd41b..cd501c68f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,6 +54,15 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
SET(ETC_PREFIX /usr/local/etc)
SET(PREFIX /usr/local)
ENDIF(NOT ETC_PREFIX)
+ FIND_LIBRARY(LIBINTL_LIBRARY NAMES intl PATHS /lib
+ /opt/lib
+ /usr/lib
+ /usr/local/lib
+ DOC "Path where the libintl library can be found")
+ LIST(APPEND CMAKE_REQUIRED_LIBRARIES ${LIBINTL_LIBRARY})
+
+ ENDIF(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
+
LIST(APPEND CMAKE_REQUIRED_LIBRARIES intl)
ENDIF(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
@@ -65,7 +74,12 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
SET(ETC_PREFIX /usr/local/etc)
SET(PREFIX /usr/local)
ENDIF(NOT ETC_PREFIX)
- LIST(APPEND CMAKE_REQUIRED_LIBRARIES intl)
+ FIND_LIBRARY(LIBINTL_LIBRARY NAMES intl PATHS /lib
+ /opt/lib
+ /usr/lib
+ /usr/local/lib
+ DOC "Path where the libintl library can be found")
+ LIST(APPEND CMAKE_REQUIRED_LIBRARIES ${LIBINTL_LIBRARY})
ENDIF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")