aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rambler-co.ru>2012-07-03 19:45:03 +0400
committerVsevolod Stakhov <vsevolod@rambler-co.ru>2012-07-03 19:45:03 +0400
commit4c1013a28f6cb90735c4554b8946414c44f28fdc (patch)
treeb2b044be3c390572767eb8d6a5cdb221fcb7d06b /CMakeLists.txt
parent932b1315504b5c2b700742d508f09bacbc6043fc (diff)
downloadrspamd-4c1013a28f6cb90735c4554b8946414c44f28fdc.tar.gz
rspamd-4c1013a28f6cb90735c4554b8946414c44f28fdc.zip
Use gmime-2.6 if gmime-2.4 is not found.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a4924d93..2ffe3ae30 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -466,7 +466,10 @@ ENDIF(HIREDIS_FOUND)
# Try to link with gmime24
IF(NOT GMIME2_FOUND OR FORCE_GMIME24)
- pkg_check_modules(GMIME24 REQUIRED gmime-2.4)
+ pkg_check_modules(GMIME24 gmime-2.4)
+ IF(NOT GMIME24_FOUND)
+ pkg_check_modules(GMIME24 REQUIRED gmime-2.6)
+ ENDIF(NOT GMIME24_FOUND)
SET(GMIME24 "yes")
# Gmime2
FOREACH(arg ${GMIME24_CFLAGS})