aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rambler-co.ru>2012-06-07 19:06:09 +0400
committerVsevolod Stakhov <vsevolod@rambler-co.ru>2012-06-07 19:06:09 +0400
commit73ded9877fc31f8c1ff5818b643edb7d7c4ea788 (patch)
tree97a94ceb14fb963a61d414f3d20d44541a533fdb /CMakeLists.txt
parenta44b10c0a88a70921f1eec9ced4b3ef0f0e01b4e (diff)
downloadrspamd-73ded9877fc31f8c1ff5818b643edb7d7c4ea788.tar.gz
rspamd-73ded9877fc31f8c1ff5818b643edb7d7c4ea788.zip
Avoid using global 'counters' hash, include it in struct rspamd_main.
Move worker related utils to separate file and include it in rspamd-mime library. Add some cross-dependencies.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3279b761f..cde158b15 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,6 +98,8 @@ IF(CMAKE_INSTALL_PREFIX)
SET(PREFIX ${CMAKE_INSTALL_PREFIX})
ENDIF(CMAKE_INSTALL_PREFIX)
+LIST(APPEND CMAKE_REQUIRED_LIBRARIES m)
+
# Try to detect platform for further configuration
CHECK_C_SOURCE_COMPILES ("#if !defined(__x86_64) && !defined(__amd64) && !defined(_M_X64)
#error assume 32 bit arch
@@ -934,11 +936,12 @@ IF(NOT HIREDIS_FOUND)
INCLUDE_DIRECTORIES("${CMAKE_CURRENT_SOURCE_DIR}/contrib/hiredis")
ENDIF(NOT HIREDIS_FOUND)
+
ADD_SUBDIRECTORY(src/lua)
ADD_SUBDIRECTORY(src/json)
ADD_SUBDIRECTORY(src/cdb)
-
ADD_SUBDIRECTORY(lib)
+
ADD_SUBDIRECTORY(src/client)
ADD_SUBDIRECTORY(utils)
@@ -1011,7 +1014,6 @@ TARGET_LINK_LIBRARIES(rspamd hiredis)
IF(GLIB_COMPAT)
TARGET_LINK_LIBRARIES(rspamd glibadditions)
ENDIF(GLIB_COMPAT)
-TARGET_LINK_LIBRARIES(rspamd m)
##################### INSTALLATION ##########################################