aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2016-02-02 23:42:42 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2016-02-02 23:42:42 +0000
commit63f8b66c21b2731408f34d7ab4a2d09d2e41cc2f (patch)
treec921bf01006b5a0b4ee8122bcde547d973ce4d28 /CMakeLists.txt
parent29f54d263c352640cfcf386a062f5ff37b401f7e (diff)
downloadrspamd-63f8b66c21b2731408f34d7ab4a2d09d2e41cc2f.tar.gz
rspamd-63f8b66c21b2731408f34d7ab4a2d09d2e41cc2f.zip
Add plain open file API method
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4332e3f1..2f3a01660 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -876,6 +876,7 @@ CHECK_SYMBOL_EXISTS(PCRE_CONFIG_JIT "pcre.h" HAVE_PCRE_JIT)
CHECK_SYMBOL_EXISTS(SOCK_SEQPACKET "sys/types.h;sys/socket.h" HAVE_SOCK_SEQPACKET)
CHECK_SYMBOL_EXISTS(I_SETSIG "sys/types.h;sys/ioctl.h" HAVE_SETSIG)
CHECK_SYMBOL_EXISTS(O_ASYNC "sys/types.h;sys/fcntl.h" HAVE_OASYNC)
+CHECK_SYMBOL_EXISTS(O_NOFOLLOW "sys/types.h;sys/fcntl.h" HAVE_ONOFOLLOW)
# Some PCRE implementations are lacking of pcre_jit_exec fast path
SET(_PCRE_FAST_TEST "