aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2016-07-05 12:57:58 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2016-07-05 12:57:58 +0100
commit2d0e4061c78be4c7d1fc713a7e2f199f26134658 (patch)
treeeb68a54f825e13e7e1652820a37a7fe8fefeedc6 /CMakeLists.txt
parent39fec823f124a82dd6a4bcd06a53a0ff062f4ac0 (diff)
downloadrspamd-2d0e4061c78be4c7d1fc713a7e2f199f26134658.tar.gz
rspamd-2d0e4061c78be4c7d1fc713a7e2f199f26134658.zip
[Minor] Fix couple of warnings and disable -pedantic mode
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40b4907a6..608f5d5df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -762,9 +762,9 @@ ENDIF(SUPPORT_WPOINTER_SIGN)
IF(SUPPORT_WSTRICT_PROTOTYPES)
SET(CMAKE_C_WARN_FLAGS "${CMAKE_C_WARN_FLAGS} -Wstrict-prototypes")
ENDIF(SUPPORT_WSTRICT_PROTOTYPES)
-IF(SUPPORT_PEDANTIC_FLAG)
- SET(CMAKE_C_WARN_FLAGS "${CMAKE_C_WARN_FLAGS} -pedantic")
-ENDIF(SUPPORT_PEDANTIC_FLAG)
+#IF(SUPPORT_PEDANTIC_FLAG)
+# SET(CMAKE_C_WARN_FLAGS "${CMAKE_C_WARN_FLAGS} -pedantic")
+#ENDIF(SUPPORT_PEDANTIC_FLAG)
IF(SUPPORT_WNULL_DEREFERENCE)
SET(CMAKE_C_WARN_FLAGS "${CMAKE_C_WARN_FLAGS} -Wnull-dereference")
ENDIF()