aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnton Yuzhaninov <citrin+git@citrin.ru>2018-10-29 23:33:36 -0400
committerAnton Yuzhaninov <citrin+git@citrin.ru>2018-10-29 23:33:36 -0400
commita796cd7321dd994a660d524ee72d6d117e8f7454 (patch)
tree1c1e8a3147c96231591d633119f6b3c9c3d1cf1a /CMakeLists.txt
parentd4c2bd7ca0e17678ff24a469bc5cad8c2363dbf5 (diff)
downloadrspamd-a796cd7321dd994a660d524ee72d6d117e8f7454.tar.gz
rspamd-a796cd7321dd994a660d524ee72d6d117e8f7454.zip
Don't set PREFIX variable in cmake
As I can see this variable is not used by rspamd build system. Remove it because setting it causes a lot of warning with -DENABLE_CLANG_PLUGIN=ON - PREFIX variable is not documented but used by cmake internally.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0aa91aa57..925408f8c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -506,10 +506,6 @@ INCLUDE_DIRECTORIES("${CMAKE_SOURCE_DIR}/"
"${CMAKE_BINARY_DIR}/src" #Stored in the binary dir
"${CMAKE_BINARY_DIR}/src/libcryptobox")
-IF(CMAKE_INSTALL_PREFIX)
- SET(PREFIX ${CMAKE_INSTALL_PREFIX})
-ENDIF(CMAKE_INSTALL_PREFIX)
-
LIST(APPEND CMAKE_REQUIRED_LIBRARIES m)
SET(POE_LOOP "Loop::IO_Poll")