aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2016-02-12 13:34:17 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2016-02-12 13:34:17 +0000
commitd54124d738a0e30d2b3b9adb1966374935ff3f46 (patch)
tree26fdb2a5582c81b865d94a12064a45a086fd35bc /CMakeLists.txt
parentd8e99a0ecd83177911d10e395ee7490af91008d1 (diff)
downloadrspamd-d54124d738a0e30d2b3b9adb1966374935ff3f46.tar.gz
rspamd-d54124d738a0e30d2b3b9adb1966374935ff3f46.zip
Add versions to rspamd modules and workers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33dcf5cbf..55611a75a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,11 @@ SET(RSPAMD_VERSION_MAJOR 1)
SET(RSPAMD_VERSION_MINOR 2)
SET(RSPAMD_VERSION_PATCH 0)
+# Keep two digits all the time
+SET(RSPAMD_VERSION_MAJOR_NUM ${RSPAMD_VERSION_MAJOR}0)
+SET(RSPAMD_VERSION_MINOR_NUM ${RSPAMD_VERSION_MINOR}0)
+SET(RSPAMD_VERSION_PATCH_NUM ${RSPAMD_VERSION_PATCH}0)
+
IF(GIT_ID)
SET(GIT_VERSION 1)
SET(RSPAMD_ID "${GIT_ID}")