aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2019-02-14 11:22:07 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2019-02-14 11:22:07 +0000
commite550b8e7db3fef4ac94bc84f6ff9012643c9c272 (patch)
tree920d47e76e55598ba8ec692d87868b5c9dec1476 /CMakeLists.txt
parentb53c6ab237de8c7a003126422c57f86e4bbbf171 (diff)
downloadrspamd-e550b8e7db3fef4ac94bc84f6ff9012643c9c272.tar.gz
rspamd-e550b8e7db3fef4ac94bc84f6ff9012643c9c272.zip
[Minor] Try to fix linking hell
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e20c6f8d..19a796768 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1225,12 +1225,6 @@ SET(WITH_HIREDIS 1)
INCLUDE_DIRECTORIES(BEFORE "${CMAKE_SOURCE_DIR}/contrib/hiredis")
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES "${CMAKE_REQUIRED_LIBRARIES}")
-LIST(APPEND RSPAMD_REQUIRED_LIBRARIES ucl)
-LIST(APPEND RSPAMD_REQUIRED_LIBRARIES rdns)
-LIST(APPEND RSPAMD_REQUIRED_LIBRARIES ottery)
-LIST(APPEND RSPAMD_REQUIRED_LIBRARIES event)
-LIST(APPEND RSPAMD_REQUIRED_LIBRARIES xxhash)
-LIST(APPEND RSPAMD_REQUIRED_LIBRARIES rspamd-actrie)
IF(HAVE_FETCH_H)
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES fetch)
ENDIF(HAVE_FETCH_H)
@@ -1238,8 +1232,12 @@ IF(WITH_DB)
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES db)
ENDIF(WITH_DB)
-
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES "${LUA_LIBRARY}")
+LIST(APPEND RSPAMD_REQUIRED_LIBRARIES ucl)
+LIST(APPEND RSPAMD_REQUIRED_LIBRARIES rdns)
+LIST(APPEND RSPAMD_REQUIRED_LIBRARIES ottery)
+LIST(APPEND RSPAMD_REQUIRED_LIBRARIES event)
+LIST(APPEND RSPAMD_REQUIRED_LIBRARIES xxhash)
IF(GLIB_COMPAT)
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES glibadditions)