aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-02-16 16:35:18 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-02-16 16:35:18 +0000
commit195bfd320c83a04728faf213b38346b18b28d5a0 (patch)
tree3600a6b395ee6b403d4cc869b7ff45b08958384a /CMakeLists.txt
parent858dd01f283427ba7554de1ccebbbf5eec18aaf3 (diff)
downloadrspamd-195bfd320c83a04728faf213b38346b18b28d5a0.tar.gz
rspamd-195bfd320c83a04728faf213b38346b18b28d5a0.zip
Import lua-functional for plugins stuff.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4d701dd1..5842c30a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1011,6 +1011,9 @@ FOREACH(LUA_PLUGIN ${LUA_PLUGINS})
INSTALL(FILES "src/plugins/lua/${LUA_PLUGIN}" DESTINATION ${PLUGINSDIR}/lua/${_rp})
ENDFOREACH(LUA_PLUGIN)
+# Install lua fun library
+INSTALL(FILES "contrib/lua-fun/fun.lua" DESTINATION ${PLUGINSDIR}/fun.lua)
+
# Lua config
INSTALL(CODE "FILE(MAKE_DIRECTORY \$ENV{DESTDIR}${CONFDIR}/lua)")
FILE(GLOB_RECURSE LUA_CONFIGS RELATIVE "${CMAKE_CURRENT_SOURCE_DIR}/conf/lua"