aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-11-12 14:34:07 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-11-12 14:34:07 +0000
commit620bcca373ef162c6597cf818a4763722cea8853 (patch)
treeaa37d3c1877b17b6c2ea2de32825c2df368c1432 /CMakeLists.txt
parent35f1eb09c64e8d32e07b1229224123f5b9feb6f2 (diff)
downloadrspamd-620bcca373ef162c6597cf818a4763722cea8853.tar.gz
rspamd-620bcca373ef162c6597cf818a4763722cea8853.zip
Perl is merely needed when snowball is enabled
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6b916f1e..a752dd0c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -151,7 +151,9 @@ INCLUDE(CheckCCompilerFlag)
INCLUDE(CMakeParseArguments)
FIND_PACKAGE(PkgConfig REQUIRED)
-FIND_PACKAGE(Perl REQUIRED)
+IF (ENABLE_SNOWBALL MATCHES "ON")
+ FIND_PACKAGE(Perl REQUIRED)
+ENDIF()
############################# MACRO SECTION #############################################