aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-02-21 18:11:12 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-02-21 18:11:12 +0000
commit6e121a026ffd681418cc8e43647afacdd13f149a (patch)
treedc02aa9d0c2a46afc53886f498844bfaa958124d /CMakeLists.txt
parentf9d2d85d1473ae53c13c99747ef809649f5137bf (diff)
downloadrspamd-6e121a026ffd681418cc8e43647afacdd13f149a.tar.gz
rspamd-6e121a026ffd681418cc8e43647afacdd13f149a.zip
Move ucl and rdns to contrib.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 25d9cfb5b..89d1cd401 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -887,7 +887,7 @@ ENDIF(HG)
INCLUDE_DIRECTORIES("${CMAKE_SOURCE_DIR}/src"
"${CMAKE_BINARY_DIR}/src"
"${CMAKE_BINARY_DIR}/src/libcryptobox"
- "${CMAKE_SOURCE_DIR}/src/ucl/include"
+ "${CMAKE_SOURCE_DIR}/contrib/libucl"
"${CMAKE_SOURCE_DIR}/contrib/uthash"
"${CMAKE_SOURCE_DIR}/contrib/http-parser"
"${CMAKE_SOURCE_DIR}/contrib/libottery"
@@ -895,7 +895,7 @@ INCLUDE_DIRECTORIES("${CMAKE_SOURCE_DIR}/src"
"${CMAKE_SOURCE_DIR}/contrib/snowball/include"
"${CMAKE_SOURCE_DIR}/contrib/siphash"
"${CMAKE_SOURCE_DIR}/contrib/blake2"
- "${CMAKE_SOURCE_DIR}/src/rdns/include")
+ "${CMAKE_SOURCE_DIR}/contrib/librdns")
################################ SUBDIRS SECTION ###########################
@@ -916,7 +916,6 @@ LIST(APPEND RSPAMD_REQUIRED_LIBRARIES xxhash)
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES siphash)
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES blake2)
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES sqlite3)
-LIST(APPEND RSPAMD_REQUIRED_LIBRARIES lua-ucl)
IF(OPENSSL_FOUND)
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES ${OPENSSL_LIBRARIES})
ENDIF(OPENSSL_FOUND)
@@ -949,6 +948,8 @@ ADD_SUBDIRECTORY(contrib/libottery)
ADD_SUBDIRECTORY(contrib/snowball)
ADD_SUBDIRECTORY(contrib/siphash)
ADD_SUBDIRECTORY(contrib/blake2)
+ADD_SUBDIRECTORY(contrib/libucl)
+ADD_SUBDIRECTORY(contrib/librdns)
ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(test)