aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Lewis <nerf@judo.za.org>2016-07-22 13:51:04 +0100
committerAndrew Lewis <nerf@judo.za.org>2016-07-22 13:51:04 +0100
commit72fbc5e84925bfc175d1ee3eab4bad48c3809ac3 (patch)
treeebfe1505d68aa60b85b273694c35faae2f966c85 /CMakeLists.txt
parent559ba376145554ccc9de3540cb6243af84381578 (diff)
downloadrspamd-72fbc5e84925bfc175d1ee3eab4bad48c3809ac3.tar.gz
rspamd-72fbc5e84925bfc175d1ee3eab4bad48c3809ac3.zip
[Fix] Skip setting RPATH for static builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9288e7ae4..fd5a51916 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -160,6 +160,7 @@ SET(RSPAMD_DEFAULT_LIBRARY_PATHS "/usr/local;/usr/pkg;/usr;/Library/Frameworks;/
IF(ENABLE_STATIC MATCHES "ON")
MESSAGE(STATUS "Static build of rspamd implies that the target binary will be *GPL* licensed")
SET(GPL_RSPAMD_BINARY 1)
+ SET(CMAKE_SKIP_INSTALL_RPATH ON)
SET(BUILD_STATIC 1)
SET(CMAKE_FIND_LIBRARY_SUFFIXES ".a")
SET(BUILD_SHARED_LIBRARIES OFF)