aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2013-12-19 18:12:05 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2013-12-19 18:12:05 +0000
commit803fde1b137899ad5cf4102989a49b993daa88d5 (patch)
tree6a4082ae05a364c5cedea679af74b660ed3fd2a5 /CMakeLists.txt
parentc2788dafc65595414bc8ce3979758e22d183d6e8 (diff)
downloadrspamd-803fde1b137899ad5cf4102989a49b993daa88d5.tar.gz
rspamd-803fde1b137899ad5cf4102989a49b993daa88d5.zip
Do not link unneeded libraries if possible.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 87002f373..0c59a42b6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -334,6 +334,7 @@ IF(CMAKE_SYSTEM_NAME STREQUAL "Linux")
ELSE(EXISTS "/etc/debian_version")
SET(LINUX_START_SCRIPT "rspamd_rh.in")
ENDIF(EXISTS "/etc/debian_version")
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--as-needed")
ENDIF(CMAKE_SYSTEM_NAME STREQUAL "Linux")
IF(CMAKE_SYSTEM_NAME STREQUAL "SunOS")