aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Vaněk <pv@excello.cz>2019-12-13 10:32:22 +0100
committerPetr Vaněk <pv@excello.cz>2019-12-13 10:32:22 +0100
commitb8ad68e9e665aa6d6716d12c5eaff780bf162e97 (patch)
tree08cb65147c791b342e4e5834d41425baa01a2f59 /CMakeLists.txt
parentf3587ce1bebb7fcaf529f796dbcec6e436253c05 (diff)
downloadrspamd-b8ad68e9e665aa6d6716d12c5eaff780bf162e97.tar.gz
rspamd-b8ad68e9e665aa6d6716d12c5eaff780bf162e97.zip
Append CXX to the list of needed languages
The replxx is written in C++ and it is enabled by default. We need to specify this to correctly pass user specific CXXFLAGS.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7cd5ef398..155e317ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,7 +21,7 @@ ENDIF()
SET(RSPAMD_VERSION "${RSPAMD_VERSION_MAJOR}.${RSPAMD_VERSION_MINOR}")
-PROJECT(rspamd VERSION "${RSPAMD_VERSION}" LANGUAGES C ASM)
+PROJECT(rspamd VERSION "${RSPAMD_VERSION}" LANGUAGES C CXX ASM)
# This is supported merely with cmake 3.1
SET(CMAKE_C_STANDARD 11)