aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2015-03-17 21:57:23 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2015-03-17 21:57:23 +0000
commitcc544380dd8034bdedbb51211a96cd6119546f7d (patch)
tree523ad30eb762d16035590a78f53f098d46c89532 /CMakeLists.txt
parenta261edfcd621ffc5e310e49c6e8aef2502ab434d (diff)
parent63b38d572fd0bc2fe57daeaa51a03a5ef4c83fad (diff)
downloadrspamd-cc544380dd8034bdedbb51211a96cd6119546f7d.tar.gz
rspamd-cc544380dd8034bdedbb51211a96cd6119546f7d.zip
Merge pull request #225 from fatalbanana/master
Try include rspamd.conf.local.override with high priority
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 25df1a574..070f418d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,9 @@ IF(NOT RSPAMD_USER)
SET(RSPAMD_GROUP "nobody")
ENDIF(NOT RSPAMD_USER)
+# Default for SysV Init
+SET(RSPAMD_WORKER_NORMAL "*:11333")
+SET(RSPAMD_WORKER_CONTROLLER "*:11334")
CMAKE_MINIMUM_REQUIRED(VERSION 2.8.0 FATAL_ERROR)
SET_PROPERTY(GLOBAL PROPERTY ALLOW_DUPLICATE_CUSTOM_TARGETS 1)
@@ -1013,16 +1016,17 @@ CONFIGURE_FILE(config.h.in src/config.h)
CONFIGURE_FILE(contrib/exim/local_scan.c.in contrib/exim/local_scan_rspamd.c @ONLY)
SET(CONFFILES
+ conf/common.conf
conf/composites.conf
- conf/logging.conf
conf/metrics.conf
conf/modules.conf
- conf/options.conf
- conf/rspamd.conf
conf/statistic.conf
- conf/workers.conf
conf/2tld.inc
- conf/surbl-whitelist.inc)
+ conf/logging.inc
+ conf/options.inc
+ conf/surbl-whitelist.inc
+ conf/worker-controller.inc
+ conf/worker-normal.inc)
##################### INSTALLATION ##########################################