aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2014-02-04 16:35:58 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2014-02-04 16:37:37 +0000
commitff62d93b0ed2051a2ba5c9cd9c12dd80c2890765 (patch)
treeaddc18a41900c3ca04cae760b10618e78c4918f1 /CMakeLists.txt
parentd07102a78273a786b2d35d154173f2c4aff0cb27 (diff)
downloadrspamd-ff62d93b0ed2051a2ba5c9cd9c12dd80c2890765.tar.gz
rspamd-ff62d93b0ed2051a2ba5c9cd9c12dd80c2890765.zip
Use libottery for secure random numbers.
Libottery itself is hosted here: https://github.com/nmathewson/libottery This import is a rough adoptation of libottery to use it for secure random numbers in rspamd when needed (and in DNS resolver specifically). This import makes the internal chacha20 code useless, hence it is removed now.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09da6c285..5eed2f089 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -877,7 +877,8 @@ INCLUDE_DIRECTORIES("${CMAKE_SOURCE_DIR}/src"
"${CMAKE_BINARY_DIR}/src"
"${CMAKE_SOURCE_DIR}/src/ucl/include"
"${CMAKE_SOURCE_DIR}/contrib/uthash"
- "${CMAKE_SOURCE_DIR}/contrib/http-parser")
+ "${CMAKE_SOURCE_DIR}/contrib/http-parser"
+ "${CMAKE_SOURCE_DIR}/contrib/libottery")
SET(RSPAMDSRC src/modules.c
src/controller.c
@@ -919,6 +920,7 @@ ADD_SUBDIRECTORY(src/json)
ADD_SUBDIRECTORY(src/cdb)
ADD_SUBDIRECTORY(src/ucl)
ADD_SUBDIRECTORY(contrib/http-parser)
+ADD_SUBDIRECTORY(contrib/libottery)
ADD_SUBDIRECTORY(src)
ADD_SUBDIRECTORY(src/client)