aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2018-03-08 14:04:09 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2018-03-08 14:04:09 +0000
commit84ff312c7a9ee30140f022c3707bb73cbff75738 (patch)
tree26807fe87a04208bc0e33594a7c2482694756f70 /CMakeLists.txt
parent64aae006eac5d533c1076e62b90c90c61fef72a3 (diff)
downloadrspamd-84ff312c7a9ee30140f022c3707bb73cbff75738.tar.gz
rspamd-84ff312c7a9ee30140f022c3707bb73cbff75738.zip
[Minor] Fix replacement op
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8be4e65b..e96bb80cf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -427,7 +427,7 @@ MACRO(ProcessPackage PKG_NAME)
IF(_incl AND _lib)
# We need to apply heuristic to find the real dir name
STRING(REGEX REPLACE "/[^/]+$" "" _incl_path "${PKG_INCLUDE}")
- STRING(REPLACE "${_incl_path}/" "" _stripped_incl "${_incl}")
+ STRING(REGEX REPLACE "${_incl_path}/$" "" _stripped_incl "${_incl}")
GET_FILENAME_COMPONENT(_lib_path "${_lib}" PATH)
INCLUDE_DIRECTORIES("${_stripped_incl}")
LINK_DIRECTORIES("${_lib_path}")