aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2019-08-16 15:54:30 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2019-08-16 15:54:30 +0100
commit30298909543453ebe969878f1406ee76ad148494 (patch)
treed1186e83ac42ca79d7926332ffc2a8cbdc3c3a6b /CMakeLists.txt
parentda9a40771dc063e8773542a1c8d278f651d1b0fc (diff)
downloadrspamd-30298909543453ebe969878f1406ee76ad148494.tar.gz
rspamd-30298909543453ebe969878f1406ee76ad148494.zip
[Minor] Add lua bit library if not luajit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d108f51e3..0cc4f91e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1180,6 +1180,10 @@ ADD_SUBDIRECTORY(contrib/t1ha)
ADD_SUBDIRECTORY(contrib/libev)
ADD_SUBDIRECTORY(contrib/kann)
+IF (NOT WITH_LUAJIT)
+ ADD_SUBDIRECTORY(contrib/lua-bit)
+ENDIF()
+
IF (ENABLE_SNOWBALL MATCHES "ON")
LIST(APPEND RSPAMD_REQUIRED_LIBRARIES stemmer)
ENDIF()