aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@utahime.org>2021-11-14 17:18:09 +0900
committerYasuhiro Kimura <yasu@utahime.org>2021-11-14 17:24:40 +0900
commite447e6c2057a5ab68fcbfe307249e54d2dadf017 (patch)
tree086bc94565a9fae8fccbe8084fbb9164fd5d7bad /CMakeLists.txt
parent6e83edb70ade9e6b8d8b69cb206dcdedbf588a69 (diff)
downloadrspamd-e447e6c2057a5ab68fcbfe307249e54d2dadf017.tar.gz
rspamd-e447e6c2057a5ab68fcbfe307249e54d2dadf017.zip
Enable PCRE2 by default.
There are 2 major versions of the PCRE library, PCRE and PCRE2. Rspamd supports both and current default is the former. But according to the web page of PCRE library it has reached its end of life. So change the default to the latter.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7af24c5ee..c4d788068 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,7 +51,7 @@ OPTION(INSTALL_WEBUI "Install web interface [default: ON]"
OPTION(WANT_SYSTEMD_UNITS "Install systemd unit files on Linux [default: OFF]" OFF)
OPTION(ENABLE_SNOWBALL "Enable snowball stemmer [default: ON]" ON)
OPTION(ENABLE_CLANG_PLUGIN "Enable clang static analysing plugin [default: OFF]" OFF)
-OPTION(ENABLE_PCRE2 "Enable pcre2 instead of pcre [default: OFF]" OFF)
+OPTION(ENABLE_PCRE2 "Enable pcre2 instead of pcre [default: ON]" ON)
OPTION(ENABLE_JEMALLOC "Build rspamd with jemalloc allocator [default: OFF]" OFF)
OPTION(ENABLE_UTILS "Build rspamd internal utils [default: OFF]" OFF)
OPTION(ENABLE_LIBUNWIND "Use libunwind to print crash traces [default: OFF]" OFF)