aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@rambler-co.ru>2013-01-05 20:29:26 +0400
committerVsevolod Stakhov <vsevolod@rambler-co.ru>2013-01-05 20:29:26 +0400
commit393a7c39ecc9224faa7c11afc32c8e74f54ea3c5 (patch)
tree4082f7e479ada5b1002ca1592ad8577f745de0f1 /CMakeLists.txt
parent6de87da477a194e566e3c672d5d41da743d6641d (diff)
downloadrspamd-393a7c39ecc9224faa7c11afc32c8e74f54ea3c5.tar.gz
rspamd-393a7c39ecc9224faa7c11afc32c8e74f54ea3c5.zip
Add webui handler for rspamd (skeleton).
Fix url detector. Add group option for modules options. Some fixes in controller and rrd code.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f41f56bf..0432fc3c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -935,6 +935,7 @@ SET(RSPAMDSRC src/modules.c
src/map.c
src/smtp.c
src/smtp_proxy.c
+ src/webui.c
src/worker.c)
SET(PLUGINSSRC src/plugins/surbl.c
@@ -945,7 +946,7 @@ SET(PLUGINSSRC src/plugins/surbl.c
src/plugins/dkim_check.c)
SET(MODULES_LIST surbl regexp chartable fuzzy_check spf dkim)
-SET(WORKERS_LIST normal controller smtp smtp_proxy lmtp fuzzy keystorage lua)
+SET(WORKERS_LIST normal controller smtp smtp_proxy lmtp fuzzy keystorage lua webui)
AddModules(MODULES_LIST WORKERS_LIST)