aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2018-02-18 17:08:48 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2018-02-18 17:08:48 +0000
commit6ecb7d259df0c2fe07e3ea99442c1d9228033ee8 (patch)
tree425937594438dbd438657b70e090fcc36b27590e /CMakeLists.txt
parent8f419996786af380a3bc96ddc55d3a295991d7ef (diff)
downloadrspamd-6ecb7d259df0c2fe07e3ea99442c1d9228033ee8.tar.gz
rspamd-6ecb7d259df0c2fe07e3ea99442c1d9228033ee8.zip
[Fix] Add workaround for system with non-XSI compatible tzset
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1ba6e7672..865bef735 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -920,6 +920,15 @@ CHECK_C_SOURCE_COMPILES(
int main(int argc, char** argv) {
return cmkcheckweak == NULL;
}" HAVE_WEAK_SYMBOLS)
+CHECK_C_SOURCE_COMPILES(
+ "#include <time.h>
+ extern char *tzname[2];
+ extern long timezone;
+ extern int daylight;
+ int main(int argc, char** argv) {
+ tzset();
+ return timezone;
+ }" HAVE_SANE_TZSET)
IF(WITH_ICONV)
CHECK_C_SOURCE_COMPILES("