aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2018-07-26 16:05:15 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2018-07-26 16:05:15 +0100
commitfcf1677b2eb3955d62d657370aaad3f2d7247950 (patch)
treeefa092265f7dc851d6a0595d03c2c99cae6335c5 /CMakeLists.txt
parent3bb8050316ac058839ed3bec79a20186e929ebd2 (diff)
downloadrspamd-fcf1677b2eb3955d62d657370aaad3f2d7247950.tar.gz
rspamd-fcf1677b2eb3955d62d657370aaad3f2d7247950.zip
[Minor] Fix build on NetBSD
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0daf244a7..3d43120c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -533,6 +533,9 @@ IF(CMAKE_SYSTEM_NAME MATCHES "^.*BSD$|DragonFly")
CHECK_FUNCTION_EXISTS(pidfile_open HAVE_PIDFILE)
CHECK_FUNCTION_EXISTS(pidfile_fileno HAVE_PIDFILE_FILENO)
ENDIF()
+ IF(CMAKE_SYSTEM_NAME MATCHES "^NetBSD$")
+ LIST(APPEND CMAKE_REQUIRED_LIBRARIES rt)
+ ENDIF()
SET(POE_LOOP "Loop::Kqueue")
SET(TAR "gtar")
ENDIF()