aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/google-ced/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2020-05-26 14:02:29 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2020-05-26 14:02:29 +0100
commit642a7f9a075c5f683d5b62c729317c30b2f5fc83 (patch)
tree2a48b658f0f43f89e81e64d4846ea4c3480acd69 /contrib/google-ced/CMakeLists.txt
parentefe1fd3c0c2506b2131956699cb74ff1dd7051e5 (diff)
downloadrspamd-642a7f9a075c5f683d5b62c729317c30b2f5fc83.tar.gz
rspamd-642a7f9a075c5f683d5b62c729317c30b2f5fc83.zip
[Minor] Fix some compile issues
Diffstat (limited to 'contrib/google-ced/CMakeLists.txt')
-rw-r--r--contrib/google-ced/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/contrib/google-ced/CMakeLists.txt b/contrib/google-ced/CMakeLists.txt
index 7fa698da9..668c6352c 100644
--- a/contrib/google-ced/CMakeLists.txt
+++ b/contrib/google-ced/CMakeLists.txt
@@ -10,11 +10,8 @@ set(CMAKE_SUPPRESS_DEVELOPER_WARNINGS 1 CACHE INTERNAL "No dev warnings")
option(BUILD_SHARED_LIBS "Build shared libraries" OFF)
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-narrowing")
-elseif("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-c++11-narrowing")
-endif()
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wno-narrowing")
include_directories(${CMAKE_CURRENT_SOURCE_DIR})