aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/http-parser/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2019-03-05 22:51:29 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2019-03-05 22:51:29 +0000
commit9bfff1d4775e19ce85272f61aecd64ce69b6a98a (patch)
tree53cede6206a0159c27fcdbc8798ba425ade19cfa /contrib/http-parser/CMakeLists.txt
parentaa98ae97e6cdcc04519f1647ebe9e7aab6ea5388 (diff)
downloadrspamd-9bfff1d4775e19ce85272f61aecd64ce69b6a98a.tar.gz
rspamd-9bfff1d4775e19ce85272f61aecd64ce69b6a98a.zip
[Minor] Use less aggressive optimisation level
Diffstat (limited to 'contrib/http-parser/CMakeLists.txt')
-rw-r--r--contrib/http-parser/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/contrib/http-parser/CMakeLists.txt b/contrib/http-parser/CMakeLists.txt
index 499c85e93..cb6767272 100644
--- a/contrib/http-parser/CMakeLists.txt
+++ b/contrib/http-parser/CMakeLists.txt
@@ -4,7 +4,7 @@ SET(HTTPSRC http_parser.c)
SET(HTTP_COMPILE_FLAGS "-DRSPAMD_LIB")
IF(ENABLE_FULL_DEBUG MATCHES "OFF")
if ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_C_COMPILER_ID}" STREQUAL "GNU")
- set(HTTP_COMPILE_FLAGS "${HTTP_COMPILE_FLAGS} -O3")
+ set(HTTP_COMPILE_FLAGS "${HTTP_COMPILE_FLAGS} -O2")
endif ()
ENDIF()