aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/t1ha/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2018-04-28 13:38:11 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2018-04-28 13:38:11 +0100
commit12da94dc1d36900e16d336c766bfde1cbbcf90ff (patch)
tree79dc7bf55c8640d79d2df5dd540b07607a41eb36 /contrib/t1ha/CMakeLists.txt
parent7852bacad4e123ba4309182a0bc77f6b5884c4b4 (diff)
downloadrspamd-12da94dc1d36900e16d336c766bfde1cbbcf90ff.tar.gz
rspamd-12da94dc1d36900e16d336c766bfde1cbbcf90ff.zip
[Feature] Upgrade t1ha distribution
Diffstat (limited to 'contrib/t1ha/CMakeLists.txt')
-rw-r--r--contrib/t1ha/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/contrib/t1ha/CMakeLists.txt b/contrib/t1ha/CMakeLists.txt
new file mode 100644
index 000000000..1b54c96d4
--- /dev/null
+++ b/contrib/t1ha/CMakeLists.txt
@@ -0,0 +1,14 @@
+SET(T1HASRC t1ha0.c
+ t1ha0_ia32aes_noavx.c
+ t1ha1.c
+ t1ha2.c)
+
+ADD_LIBRARY(rspamd-t1ha STATIC ${T1HASRC})
+SET_TARGET_PROPERTIES(rspamd-t1ha PROPERTIES VERSION ${RSPAMD_VERSION})
+ADD_DEFINITIONS("-DT1HA_USE_FAST_ONESHOT_READ=1")
+
+IF(ENABLE_FULL_DEBUG MATCHES "OFF")
+ if ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_C_COMPILER_ID}" STREQUAL "GNU")
+ SET_TARGET_PROPERTIES(rspamd-t1ha PROPERTIES COMPILE_FLAGS "-O3")
+ endif ()
+ENDIF()