aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/xxhash/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2014-12-19 10:55:28 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2014-12-19 10:55:28 +0000
commitdd1134f06b174f1829d81b67d7c1a6aeaf8bcc1e (patch)
treee5483eda2482a320ad834bad246fd7e0759c308d /contrib/xxhash/CMakeLists.txt
parenta13bc71723ef269d7dcee56416a5f42cd8ee8a72 (diff)
downloadrspamd-dd1134f06b174f1829d81b67d7c1a6aeaf8bcc1e.tar.gz
rspamd-dd1134f06b174f1829d81b67d7c1a6aeaf8bcc1e.zip
Compile external tools with optimizations.
Diffstat (limited to 'contrib/xxhash/CMakeLists.txt')
-rw-r--r--contrib/xxhash/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/contrib/xxhash/CMakeLists.txt b/contrib/xxhash/CMakeLists.txt
index 2cc0234d8..41c05d4e9 100644
--- a/contrib/xxhash/CMakeLists.txt
+++ b/contrib/xxhash/CMakeLists.txt
@@ -1,3 +1,6 @@
SET(XXHASHSRC xxhash.c)
+if ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_C_COMPILER_ID}" STREQUAL "GNU")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O3")
+endif ()
ADD_LIBRARY(xxhash STATIC ${XXHASHSRC}) \ No newline at end of file