summaryrefslogtreecommitdiffstats
path: root/contrib/zstd/CMakeLists.txt
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2016-12-25 16:23:02 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2016-12-25 16:23:02 +0000
commit6eecb5ce7c89b5d203b175445b338a9ddd3a1368 (patch)
tree77dffc7d2e7e9a97cc6ae514e5a0fd9e4aaf6388 /contrib/zstd/CMakeLists.txt
parentde8ca5b3ac969491416a064840f963622fd3d59c (diff)
downloadrspamd-6eecb5ce7c89b5d203b175445b338a9ddd3a1368.tar.gz
rspamd-6eecb5ce7c89b5d203b175445b338a9ddd3a1368.zip
[Minor] Add enable full debug option
Diffstat (limited to 'contrib/zstd/CMakeLists.txt')
-rw-r--r--contrib/zstd/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/contrib/zstd/CMakeLists.txt b/contrib/zstd/CMakeLists.txt
index 1b7b9d290..953839ba7 100644
--- a/contrib/zstd/CMakeLists.txt
+++ b/contrib/zstd/CMakeLists.txt
@@ -12,6 +12,9 @@ SET(ZSTDSRC divsufsort.c
zstd_decompress.c)
ADD_LIBRARY(rspamd-zstd STATIC ${ZSTDSRC})
+
+IF(ENABLE_FULL_DEBUG MATCHES "OFF")
if ("${CMAKE_C_COMPILER_ID}" STREQUAL "Clang" OR "${CMAKE_C_COMPILER_ID}" STREQUAL "GNU")
SET_TARGET_PROPERTIES(rspamd-zstd PROPERTIES COMPILE_FLAGS "-O3")
endif ()
+ENDIF()