aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2020-01-18 18:06:55 +0000
committerPeter Wu <peter@lekensteyn.nl>2020-01-18 18:06:55 +0000
commite5367bedeb56a86605de3132ec8070a6e95e3660 (patch)
treeb1eb1344850cfe495fea51e34a81a17d39f35ee4 /debian/rules
parentfcf7825b5891f9bd6b3bbfea364c7f0717b54938 (diff)
downloadrspamd-e5367bedeb56a86605de3132ec8070a6e95e3660.tar.gz
rspamd-e5367bedeb56a86605de3132ec8070a6e95e3660.zip
[Minor] Debian: Enable Hyperscan and parallel builds
Debian 9 (Stretch) ships with Hyperscan 4.4.1, Ubuntu 18.04 ships with Hyperscan 4.7.0. Follow rspamd's official recommendation and enable support for these. The --parallel option has been supported since 2009 and works perfectly with CMake, so enable it by default.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 9 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 372aaffcd..8229f2623 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,18 @@
#!/usr/bin/make -f
%:
- dh $@ --with systemd
+ dh $@ --with systemd --parallel
.PHONY: override_dh_strip
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export ASAN_OPTIONS=detect_leaks=0
+ifneq ($(filter $(DEB_TARGET_ARCH),amd64 i386),)
+ ENABLE_HYPERSCAN := -DENABLE_HYPERSCAN=ON
+else
+ ENABLE_HYPERSCAN :=
+endif
+
override_dh_auto_configure:
dh_auto_configure -- -DCONFDIR=/etc/rspamd \
-DMANDIR=/usr/share/man \
@@ -27,7 +33,8 @@ override_dh_auto_configure:
-DENABLE_LUAJIT=ON \
-DENABLE_TORCH=ON \
-DENABLE_LIBUNWIND=ON \
- -DWANT_SYSTEMD_UNITS=ON
+ -DWANT_SYSTEMD_UNITS=ON \
+ $(ENABLE_HYPERSCAN)
override_dh_makeshlibs:
dh_makeshlibs -Xrspamd-actrie