summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2020-01-20 22:25:40 +0000
committerPeter Wu <peter@lekensteyn.nl>2020-01-20 22:25:40 +0000
commit561607b0d7dfd46c5967d26b66496477bb70ff92 (patch)
treeb6641ebff5603d2a5f5800735bdde7bf612083ae /debian
parente92ab03b6b40f886c2cb81551e1a9c6c97818c3e (diff)
downloadrspamd-561607b0d7dfd46c5967d26b66496477bb70ff92.tar.gz
rspamd-561607b0d7dfd46c5967d26b66496477bb70ff92.zip
[Minor] debian/rules: move makefile targets (no functional change)
Remove .PHONY marker for consistency. Move override_dh_strip before the target dh_makeshlibs as is is executed right before that.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules12
1 files changed, 5 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index dd1f27a1e..b3a0feafc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,4 @@
#!/usr/bin/make -f
-%:
- dh $@ --with systemd --parallel
-
-.PHONY: override_dh_strip
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
export ASAN_OPTIONS=detect_leaks=0
@@ -20,6 +16,8 @@ ifneq ($(filter $(DEB_HOST_ARCH),amd64 i386),)
else
ENABLE_HYPERSCAN :=
endif
+%:
+ dh $@ --with systemd --parallel
override_dh_auto_configure:
dh_auto_configure -- -DCONFDIR=/etc/rspamd \
@@ -40,12 +38,12 @@ override_dh_auto_configure:
-DWANT_SYSTEMD_UNITS=ON \
$(ENABLE_HYPERSCAN)
-override_dh_makeshlibs:
- dh_makeshlibs -Xrspamd-actrie
-
override_dh_strip:
dh_strip --dbg-package=rspamd-dbg
+override_dh_makeshlibs:
+ dh_makeshlibs -Xrspamd-actrie
+
override_dh_auto_install:
dh_auto_install --destdir=debian/rspamd