summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorMikhail Gusarov <dottedmag@dottedmag.net>2014-02-23 09:36:40 +0100
committerVsevolod Stakhov <vsevolod@highsecure.ru>2014-02-24 13:17:46 +0000
commit68d3452120e3f285f01f9e671528bd42aaee8958 (patch)
tree2bcc3394d09f0af037d8f2dbc207ef52c9e1dc14 /debian
parent9ab8da7bf675f3c6cb270f66738ec1875e73aa57 (diff)
downloadrspamd-68d3452120e3f285f01f9e671528bd42aaee8958.tar.gz
rspamd-68d3452120e3f285f01f9e671528bd42aaee8958.zip
Use dh instead of CDBS
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules22
2 files changed, 12 insertions, 12 deletions
diff --git a/debian/control b/debian/control
index fa5c4e3a3..80065f32b 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: rspamd
Section: mail
Priority: optional
Maintainer: Mikhail Gusarov <dottedmag@debian.org>
-Build-Depends: debhelper (>= 7.0.50~), dpkg-dev (>= 1.16.1~), cmake, libevent-dev (>= 1.3), libglib2.0-dev (>= 2.16.0), libgmime-2.6-dev, liblua5.2-dev | liblua5.1-dev | liblua5.1-0-dev, libpcre3-dev, cdbs, libssl-dev (>= 1.0), libcurl4-openssl-dev, libhiredis-dev
+Build-Depends: debhelper (>= 7.0.50~), dpkg-dev (>= 1.16.1~), cmake, libevent-dev (>= 1.3), libglib2.0-dev (>= 2.16.0), libgmime-2.6-dev, liblua5.2-dev | liblua5.1-dev | liblua5.1-0-dev, libpcre3-dev, libssl-dev (>= 1.0), libcurl4-openssl-dev, libhiredis-dev
Standards-Version: 3.9.5
Homepage: https://rspamd.com
Vcs-Git: git://github.com/vstakhov/rspamd.git
diff --git a/debian/rules b/debian/rules
index 3608758ea..1128635c2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,14 +1,11 @@
#!/usr/bin/make -f
+%:
+ dh $@
-#export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
-export DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed
-
-include /usr/share/dpkg/buildflags.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-
-DEB_CMAKE_NORMAL_ARGS+= -DCONFDIR=/etc/rspamd \
+override_dh_auto_configure:
+ dh_auto_configure -- -DCONFDIR=/etc/rspamd \
-DMANDIR=/usr/share/man \
-DRUNDIR=/run/rspamd \
-DDBDIR=/var/lib/rspamd \
@@ -22,7 +19,10 @@ DEB_CMAKE_NORMAL_ARGS+= -DCONFDIR=/etc/rspamd \
-DINSTALL_EXAMPLES=ON \
-DFORCE_GMIME24=ON \
-DRSPAMD_GROUP=rspamd \
- -DRSPAMD_USER=rspamd \
- -DENABLE_HIREDIS=ON
-clean::
+ -DRSPAMD_USER=_rspamd
+# \
+# -DENABLE_HIREDIS=ON
+
+override_dh_auto_clean:
+ dh_auto_clean
rm -f src/modules.c