summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@highsecure.ru>2018-03-22 09:54:27 +0000
committerVsevolod Stakhov <vsevolod@highsecure.ru>2018-03-22 09:54:27 +0000
commit9384b6b83ffbe2ac85d57893a25da48261b033fb (patch)
tree0db44a7f589f8bece9e6669999344f1790ac05bd /debian
parent15cc0164347a8397b324709b0ef288bd421f24cc (diff)
downloadrspamd-9384b6b83ffbe2ac85d57893a25da48261b033fb.tar.gz
rspamd-9384b6b83ffbe2ac85d57893a25da48261b033fb.zip
Revert "[Minor] Use ninja to build packages"
This reverts commit 34c8e06baf7258ef5888191d7e5af1dd422baf55.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules13
1 files changed, 4 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 6fc338571..c958a26ea 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,13 @@
#!/usr/bin/make -f
%:
- dh $@ --with systemd --builddirectory=build-deb
+ dh $@ --with systemd
.PHONY: override_dh_strip
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
override_dh_auto_configure:
- dh_auto_configure -- -GNinja -DCONFDIR=/etc/rspamd \
+ dh_auto_configure -- -DCONFDIR=/etc/rspamd \
-DMANDIR=/usr/share/man \
-DRUNDIR=/run/rspamd \
-DDBDIR=/var/lib/rspamd \
@@ -38,17 +38,12 @@ override_dh_makeshlibs:
override_dh_strip:
dh_strip --dbg-package=rspamd-dbg
-override_dh_auto_build:
- ninja -C build-deb -v
-
override_dh_auto_install:
- DESTDIR=$(CURDIR)/debian/rspamd ninja -C build-deb -v install
-
-override_dh_auto_test:
+ dh_auto_install --destdir=debian/rspamd
override_dh_auto_clean:
dh_auto_clean
- rm -rf build-deb
+ rm -f src/modules.c
override_dh_fixperms:
dh_fixperms